Error: Cannot find module editions

event
docpad
problem
question
Tags: #<Tag:0x00007f8068a9ec60> #<Tag:0x00007f8068a9eaa8> #<Tag:0x00007f8068a9e828> #<Tag:0x00007f8068a9e620>

#1

I’m new here but I can’t find my issue on the net

I updated js and docpad… Please help.
Leah

    PS C:\Program Files\docpad-master> cd acmeinform
PS C:\Program Files\docpad-master\acmeinform> docpad init
module.js:549
    throw err;
    ^

Error: Cannot find module 'editions'
    at Function.Module._resolveFilename (module.js:547:15)
    at Function.Module._load (module.js:474:25)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (C:\Users\lorin\AppData\Roaming\npm\node_modules\docpad\bin\docpad:2:18)
    at Module._compile (module.js:652:30)
    at Object.Module._extensions..js (module.js:663:10)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)

There were no suitable editions for package docpad
#2

Great. Thanks for posting here. Tracking over at:


#3

this should now be resolved for most packages

resolution in docpad will take a bit longer…