Remaining Outdated Plugins

docpad
Tags: #<Tag:0x00007f4e65739de8>

#1

There are several plugins that have recently moved to the DocPad GitHub org, that require upgrading for the latest DocPad v6.80 conventions. The plugins will continue to work fine with DocPad v6.79, and will also work fine with DocPad v6.80+ via env EDITIONS_SYNTAX_BLACKLIST=esnext docpad run as documented here.

I have done the upgrades for most of them locally, however I am encountering sporadic failing tests. I suspect this is due to the use of the new docpad-plugintester test runner, instead of having the runners local. I have a suspicion of how to solve that — notably currently, the plugintester will boot a docpad instance, then load the plugin into it — while this is meant to be supported, it is very complex workflow — it would make more sense, to have it do the most common workflow where the plugin is loaded with the docpad instance — to do that, we can do "docpad-plugin-theplugin": ".." in test/package.json:dependencies as the latest npms now support that. I’ve begun work on that, however it all got pushed to the backburner.


I am currently preoccupied with tasks with revenue potential as my finances have depleted, so FOSS issues have been pushed to the backburner. If you want to speed them up on my queue, then consider making them a paid task by posting a bounty, as currently I earn nothing from my open-source work, so it cannot be a priority. Details for posting a bounty on this issue to incentivise its accomplishment sooner can be found here:

Bounty Donation Services