There were no suitable editions for package docpad


#1

I’m trying a fresh install of docpad on a windows server and have come up against the following issue:

C:\Program Files\nodejs\node_modules\docpad\node_modules\editions\edition-node-0
.8\index.js:160
                        throw new Errlop('There were no suitable editions for pa
ckage [' + opts.packagePath + ']', editionsError);
                        ^

Error: There were no suitable editions for package [C:\Program Files\nodejs\node
_modules\docpad\package.json]

I’ve tried cleaning the npm cache and reinstalling but it didn’t help.
Thanks in advance.


#2

Thanks. The current build is broken on windows. Details here:

I’ll have a fix out in a few days.

In the meantime, keep trying earlier versions until you find one that works.


#3

I think I fixed this a week or more ago, can you retry?